Autore Topic: Ho installato un LCD nel Commodore SX-64  (Letto 1451 volte)

giobbi

  • Newbie
  • *
  • Post: 3
  • Gioco Preferito: Paradroid
Ho installato un LCD nel Commodore SX-64
« il: 12 Maggio 2021, 17:17:40 »
ciao tutti,

mentre riparavo uno dei miei due SX-64, il monitor CRT ha deciso di spegnersi per sempre. Per farla breve, dopo aver invano cercato il problema, ho deciso di accantonarlo per il momento e di sostituirlo con un LCD. Se e quando riuscirò a riparare il CRT, lo rimetterò a posto.

Sul web si trova più di un modo per installare un LCD (magari in formato 4:3) che consente un risultato perfetto; però di norma si parla di spendere magari più di 100 euro. Inoltre abito in Brasile ed i tempi e le spese di spedizione mi hanno fatto desistere.

Ho comprato un monitor da 5" (formato widescreen) in China per l'equivalente di 20 €, spedizione compresa, ed ho così scoperto che il segnale composite video del Commodore 64 (e SX-64) non funziona con questi monitor. Con sto maledetto SX-64 sembra che niente vada a posto al primo colpo, ho già avuto tanti di quei problemi...

Ad ogni modo, dopo un full immersion sul web, ho scoperto che il firmware del chipset AMT630A - usato dalla maggior parte di questi monitor - può essere patchato; tuttavia la patch è al di là delle mie capacità attuali, così ho scelto invece di correggere il segnale video tramite un circuito che ho trovato on-line, basato sul circuito integrato LM 1881 più altri componenti (occhio: non è il solito sync-splitter, è un circuito diverso, apposta per questo problema).

Montato alla bene e meglio il circuito con discutibili metodi artigianali (era tanto semplice che in un tracollo di pigrizia per fare il PCB non ho neppure acceso la stampante laser, l'ho tracciato direttamente con il pennarello prima del bagno nell' "acido") e testato che funzionasse, ho fatto una piccola modifica alla main board (facilmente reversibile) in modo da avere il composite video originale sul pin #1 del connettore INT VIDEO a cui è normalmente collegato il CRT. Questo perché il circuito ha bisogno del composite video e non sono riuscito in nessun modo a combinare i due segnali Chroma e Luma del connettore per avere un composite video decente.

Dato che la circuiteria del CRT ospita anche l'amplificatore audio (sul connettore sopra citato c'è anche l'uscita audio ai pin #4 e #5), ho raccattato un vecchio amplificatore stereo che avevo tempo fa realizzato per altri scopi e che giaceva abbandonato nella scatola-purgatorio dei circuiti non più usati e l'ho adattato usando un solo canale. Ho anche collegato il potenziometro originale del volume (quello sul pannello frontale) all'amplificatore in questione, risolvendo almeno la parte relativa al controllo del volume.
Ovviamente, invece, non sono disponibili le regolazioni video; il display LCD ha un suo meno con i controlli di luminosità, contrasto, colore e tinta, ma non ho ritenuto necessario forare in alcun modo il SX-64 (che spero un giorno di poter ripristinare con il suo CRT) per renderli disponibili. Li ho lasciati all'interno, sono accessibili solo smontando il coperchio superiore.
 
Stabilito che tutto funzionava, ho provveduto a stampare in 3D la frame per il montaggio e ad assemblare il tutto.

Ho deciso di lasciare l'immagine in 16:9... non è così terribile e modificarla in 4:3 dal menu del monitor la rende davvero troppo piccola per i miei stanchi e pigri occhi di over 50...

Qui c'è il link al video su youtube, dove potete trovare anche tutti i link alle pagine che ho usato (vedi descrizione del video):

https://www.youtube.com/watch?v=1Zzk851vAZs

Guardando il video potrete altresì notare che difficilmente diventerò uno youtube professionale  ;)