Autore Topic: Problema Floppy 1581  (Letto 1230 volte)

Leo972

  • Neo-iscritto
  • *
  • Post: 11
  • Gioco Preferito: turbo out run
Problema Floppy 1581
« il: 05 Aprile 2014, 08:55:16 »
 Buongiorno a tutti,  mi sono aggiudicato un lotto su ebay composto da un commodore 64c un vic 20 e un commodore 1581 completo di alimentatore e disco demo (quello che mi interessava di più).
Mi arriva il pacco, collego il 1581 al mio commodore 64 (funzionante) e accendo.
Il commodore 1581 si accende inizializza, si sente il rumore della testina che si muove e la luce accesa verde, poi quando ha finito resta la sola luce rossa.
Inserisco il dischetto demo, scrivo il classico load"$",8 per vedere il contenuto del disco, compare la scritta loading, ma il floppy non gira,  sempre con la luce rossa e niente luce verde  lampeggiante :-(
Ho provato anche a collegarlo al pc tramite il cavo X1541 e con il software cbmfer  risco a resettare il floppy, ma quando do il comando status si accende la luce verde e resta accesa e il sotware si blocca.

Chiedo se qualcuno gentilmente mi puo' aiutare.

Andy/AEG

  • Utente
  • **
  • Post: 120
    • AEG soft
  • Gioco Preferito: Elite
Problema Floppy 1581
« Risposta #1 il: 07 Aprile 2014, 10:04:31 »
 Fai questa prova: dopo aver acceso il 1581, senza dare alcun comando di load o similari verso tale periferica, dando per assunto che il device sia configurato come 8, scrivi:

OPEN 15,8,15,"U0>B0":PRINT#15,"U0>B0":CLOSE 15

e premi RETURN.


se il difetto è scomparso... bene, dovrai farlo ogni volta che accendi o resetti il drive


A.

Flavioweb

  • Utente
  • **
  • Post: 58
    • http://www.flavioweb.it
  • Gioco Preferito: Maniac Mansion
Problema Floppy 1581
« Risposta #2 il: 07 Aprile 2014, 12:51:38 »
 Andy... solo una curiosità: a cosa serve questo comando?

Andy/AEG

  • Utente
  • **
  • Post: 120
    • AEG soft
  • Gioco Preferito: Elite
Problema Floppy 1581
« Risposta #3 il: 07 Aprile 2014, 13:58:50 »
Citazione da: "Flavioweb"
Andy... solo una curiosità: a cosa serve questo comando?

vado a memoria.. a porre la modalità slow serial sulla porta del 1581, che ne prevede due: slow e fast. La modalità doveva essere in autodetect, ma sui primi 1581 non funzionava e si settava in modalità fast, compatibile col C128 ma non col C64.

U0>B1 invece psetta la modalità Fast.

Anche io avevo (anzi ho tuttora) un 1581 con quel problema, e la soluzione alla problematica mi fu passata da un tecnico del centro di riparazione della mia città.



A.

Flavioweb

  • Utente
  • **
  • Post: 58
    • http://www.flavioweb.it
  • Gioco Preferito: Maniac Mansion
Problema Floppy 1581
« Risposta #4 il: 07 Aprile 2014, 18:36:53 »
 OK.
Grazie!

Leo972

  • Neo-iscritto
  • *
  • Post: 11
  • Gioco Preferito: turbo out run
Problema Floppy 1581
« Risposta #5 il: 08 Aprile 2014, 08:35:00 »
 Grazie Mille della gentilissima risposta, stasera provo e ti faccio sapere.
 

Leo972

  • Neo-iscritto
  • *
  • Post: 11
  • Gioco Preferito: turbo out run
Problema Floppy 1581
« Risposta #6 il: 09 Aprile 2014, 17:58:18 »
 Allora ho provato a digitare il comando che mi hai gentilmente  scritto, ma impalla la macchina, resta li ferma senza dare segnali e il floppy ha la sola luce rossa accesa :(

Andy/AEG

  • Utente
  • **
  • Post: 120
    • AEG soft
  • Gioco Preferito: Elite
Problema Floppy 1581
« Risposta #7 il: 09 Aprile 2014, 20:23:26 »
 mi spiace, allora il problema non è il bug della prima serie (relativamente noto e che si risolve con quel comando o presumo cambiando la rom).

A.

Leo972

  • Neo-iscritto
  • *
  • Post: 11
  • Gioco Preferito: turbo out run
Problema Floppy 1581
« Risposta #8 il: 18 Aprile 2014, 12:21:55 »
 Secondo te potrebbe essere un problema di rom, se la cambiassi con un jiffyDOS per il drive 1581 che vendono su ebay?
Oppure come consigliato da un ottimo venditore, cambiare il controller del floppy (drive controller 1770)